Aircrack ng kali linux github

Name already in use

aircrack-ng / README.md

  • Go to file T
  • Go to line L
  • Copy path
  • Copy permalink

Copy raw contents

Copy raw contents

Aircrack-ng is a complete suite of tools to assess WiFi network security.

It focuses on different areas of WiFi security:

  • Monitoring: Packet capture and export of data to text files for further processing by third party tools.
  • Attacking: Replay attacks, deauthentication, fake access points and others via packet injection.
  • Testing: Checking WiFi cards and driver capabilities (capture and injection).
  • Cracking: WEP and WPA PSK (WPA 1 and 2).

All tools are command line which allows for heavy scripting. A lot of GUIs have taken advantage of this feature. It works primarily on Linux but also Windows, macOS, FreeBSD, OpenBSD, NetBSD, as well as Solaris and even eComStation 2.

  • Autoconf
  • Automake
  • Libtool
  • shtool
  • OpenSSL development package or libgcrypt development package.
  • Airmon-ng (Linux) requires ethtool, usbutils, and often pciutils.
  • On Windows, cygwin has to be used and it also requires w32api package.
  • On Windows, if using clang, libiconv and libiconv-devel
  • Linux: LibNetlink 1 or 3. It can be disabled by passing —disable-libnl to configure.
  • pkg-config (pkgconf on FreeBSD)
  • FreeBSD, OpenBSD, NetBSD, Solaris and OS X with Macports: gmake
  • Linux/Cygwin: make and Standard C++ Library development package (Debian: libstdc++-dev)

Note: Airmon-ng only requires pciutils if the system has a PCI/PCIe bus and it is populated. Such bus can be present even if not physically visible. For example, it is present, and populated on the Raspberry Pi 4, therefore pciutils is required on that device.

  • If you want SSID filtering with regular expression in airodump-ng (-essid-regex) PCRE development package is required.
  • If you want to use airolib-ng and ‘-r’ option in aircrack-ng, SQLite development package >= 3.3.17 (3.6.X version or better is recommended)
  • If you want to use Airpcap, the ‘developer’ directory from the CD/ISO/SDK is required.
  • In order to build besside-ng , besside-ng-crawler , easside-ng , tkiptun-ng and wesside-ng , libpcap development package is required (on Cygwin, use the Airpcap SDK instead; see above)
  • rfkill
  • If you want Airodump-ng to log GPS coordinates, gpsd is needed
  • For best performance on SMP machines, ensure the hwloc library and headers are installed. It is strongly recommended on high core count systems, it may give a serious speed boost
  • CMocka and expect for testing
  • For integration testing on Linux only: tcpdump, HostAPd, WPA Supplicant and screen

Installing required and optional dependencies

Below are instructions for installing the basic requirements to build aircrack-ng for a number of operating systems.

Note: CMocka, tcpdump, screen, HostAPd and WPA Supplicant should not be dependencies when packaging Aircrack-ng.

Источник

ggreer/aircrack-ng

Use Git or checkout with SVN using the web URL.

Work fast with our official CLI. Learn more.

Читайте также:  Ar 202t картридж для какого принтера

Launching GitHub Desktop

If nothing happens, download GitHub Desktop and try again.

Launching GitHub Desktop

If nothing happens, download GitHub Desktop and try again.

Launching Xcode

If nothing happens, download Xcode and try again.

Launching Visual Studio Code

Your codespace will open once ready.

There was a problem preparing your codespace, please try again.

This branch is not ahead of the upstream aircrack-ng:master.

No new commits yet. Enjoy your day!

Latest commit

Git stats

Files

Failed to load latest commit information.

README.md

Aircrack-ng is an 802.11 WEP and WPA-PSK keys cracking program that can recover keys once enough data packets have been captured. It implements the standard FMS attack along with some optimizations like KoreK attacks, as well as the all-new PTW attack, thus making the attack much faster compared to other WEP cracking tools.

It can attack WPA1/2 networks with some advanced methods or simply by brute force. It can also fully use a multiprocessor system to its full power in order to speed up the cracking process.

  • OpenSSL development package or libgcrypt development package.
  • Airmon-ng (Linux) requires ethtool.
  • On windows, cygwin has to be used and it also requires w32api package.
  • Linux: LibNetlink 1 or 3. It can be disabled by setting the flag ‘libnl’ to false.
  • pkg-config (pkgconf on FreeBSD)
  • FreeBSD, OpenBSD, NetBSD, Solaris and OS X with macports: gmake
  • Linux/Cygwin: make and Standard C++ Library development package (Debian: libstdc++-dev)
  • If you want SSID filtering with regular expression in airodump-ng (-essid-regex) pcre development package is required.
  • If you want to use airolib-ng and ‘-r’ option in aircrack-ng, SQLite development package >= 3.3.17 (3.6.X version or better is recommended)
  • If you want to use Airpcap, the ‘developer’ directory from the CD is required.
  • For best performance on FreeBSD (50-70% more), install gcc5 via: pkg install gcc5 Then compile with: gmake CC=gcc5 CXX=g++5
  • rfkill

Compilation on *BSD or Solaris:

Strip debugging symbols:

When compile and installing, the following flags can be used and combined to compile and install the suite:

sqlite: Compile airolib-ng and add support for airolib-ng databases in aircrack-ng:

  • Debian based distro: libsqlite3-dev
  • FreeBSD: sqlite3

airpcap: needed for supporting airpcap devices on windows (cygwin only) REQUIREMENT: Copy ‘developers’ directory from Airpcap CD one level below this INSTALLING file Note: Not working yet.

experimental: needed to compile tkiptun-ng , easside-ng (and buddy-ng ) and wesside-ng . Building besside-ng-crawler requires LibPCAP (development package). On debian based distro, install libpcap-dev

ext_scripts: needed to build airoscript-ng , versuck-ng , airgraph-ng and airdrop-ng . Note: Experimental. Each script has its own dependences. Note: It’s only required in install phase.

gcrypt: Use libgcrypt crypto library instead of the default OpenSSL. And also use internal fast sha1 implementation (borrowed from GIT) Dependency (Debian): libgcrypt20-dev

libnl: Add support for netlink (nl80211). Linux only.

  • Requires libnl1 OR libnl3 .
  • Dependencies (debian):
    • LibNL 1: libnl-dev
    • LibNL 3: libnl-3-dev and libnl-genl-3-dev .

pcre: Add support for regular expression matching for ESSID in airodump-ng and besside-ng. Dependencies (debian): libpcre3-dev

  • Debian based distro: libpcre3-dev
  • FreeBSD: pcre
Читайте также:  Как сканировать на принтере brother dcp t420w

duma: Compile with DUMA support. DUMA is a library to detect buffer overruns and under-runs. Dependencies (debian): duma

xcode: Set this flag to true to compile on OS X with Xcode 7+.

macport: Set this flag to true to compile on OS X with macports.

make sqlite=true experimental=true pcre=true

Compiling wth gcrypt: make gcrypt=true

make sqlite=true pcre=true experimental=true install

Installing, with external scripts:

make sqlite=true experimental=true ext_scripts=true

Testing (with sqlite, experimental and pcre)

make sqlite=true experimental=true pcre=true check

Compiling on OS X with macports (and all options):

gmake macport=true sqlite=true experimental=true pcre=true

Compiling on FreeBSD with better performance

gmake CC=gcc5 CXX=g++5

Automatic detection of CPU optimization is done at compile time. This behavior is not desirable when packaging Aircrack-ng (for a Linux distribution).

It can be overriden by creating common.cfg in the same directory as this file with the following settings when compiling on x86 (32 or 64 bit):

Using precompiled binaries

  • Use your package manager to download aircrack-ng
  • In most cases, they have an old version.
  • Install the appropriate «monitor» driver for your card (standard drivers doesn’t work for capturing data).
  • aircrack-ng suite is command line tools. So, you have to open a commandline Start menu -> Run. -> cmd.exe then use them
  • Run the executables without any parameters to have help

Documentation, tutorials, . can be found on http://www.aircrack-ng.org

See also manpages and the forum.

For further information check the README file

Источник

mickstevens/aircrack-ng

Use Git or checkout with SVN using the web URL.

Work fast with our official CLI. Learn more.

Launching GitHub Desktop

If nothing happens, download GitHub Desktop and try again.

Launching GitHub Desktop

If nothing happens, download GitHub Desktop and try again.

Launching Xcode

If nothing happens, download Xcode and try again.

Launching Visual Studio Code

Your codespace will open once ready.

There was a problem preparing your codespace, please try again.

This branch is not ahead of the upstream aircrack-ng:master.

No new commits yet. Enjoy your day!

Latest commit

Git stats

Files

Failed to load latest commit information.

README.md

Aircrack-ng is an 802.11 WEP and WPA-PSK keys cracking program that can recover keys once enough data packets have been captured. It implements the standard FMS attack along with some optimizations like KoreK attacks, as well as the all-new PTW attack, thus making the attack much faster compared to other WEP cracking tools.

It can attack WPA1/2 networks with some advanced methods or simply by brute force. It can also fully use a multiprocessor system to its full power in order to speed up the cracking process.

  • OpenSSL development package or libgcrypt development package.
  • Airmon-ng (Linux) requires ethtool.
  • On windows, cygwin has to be used and it also requires w32api package.
  • Linux: LibNetlink 1 or 3. It can be disabled by setting the flag ‘libnl’ to false.
  • pkg-config (pkgconf on FreeBSD)
  • FreeBSD, OpenBSD, NetBSD, Solaris and OS X with macports: gmake
  • Linux/Cygwin: make and Standard C++ Library development package (Debian: libstdc++-dev)
  • If you want SSID filtering with regular expression in airodump-ng (-essid-regex) pcre development package is required.
  • If you want to use airolib-ng and ‘-r’ option in aircrack-ng, SQLite development package >= 3.3.17 (3.6.X version or better is recommended)
  • If you want to use Airpcap, the ‘developer’ directory from the CD is required.
  • For best performance on FreeBSD (50-70% more), install gcc5 via: pkg install gcc5 Then compile with: gmake CC=gcc5 CXX=g++5
  • rfkill
Читайте также:  0x00003712 хранилище компонентов повреждено

Compilation on *BSD or Solaris:

Strip debugging symbols:

When compile and installing, the following flags can be used and combined to compile and install the suite:

sqlite: Compile airolib-ng and add support for airolib-ng databases in aircrack-ng:

  • Debian based distro: libsqlite3-dev
  • FreeBSD: sqlite3

airpcap: needed for supporting airpcap devices on windows (cygwin only) REQUIREMENT: Copy ‘developers’ directory from Airpcap CD one level below this INSTALLING file Note: Not working yet.

experimental: needed to compile tkiptun-ng , easside-ng (and buddy-ng ) and wesside-ng . Building besside-ng-crawler requires LibPCAP (development package). On debian based distro, install libpcap-dev

ext_scripts: needed to build airoscript-ng , versuck-ng , airgraph-ng and airdrop-ng . Note: Experimental. Each script has its own dependences. Note: It’s only required in install phase.

gcrypt: Use libgcrypt crypto library instead of the default OpenSSL. And also use internal fast sha1 implementation (borrowed from GIT) Dependency (Debian): libgcrypt20-dev

libnl: Add support for netlink (nl80211). Linux only.

  • Requires libnl1 OR libnl3 .
  • Dependencies (debian):
    • LibNL 1: libnl-dev
    • LibNL 3: libnl-3-dev and libnl-genl-3-dev .

pcre: Add support for regular expression matching for ESSID in airodump-ng and besside-ng. Dependencies (debian): libpcre3-dev

  • Debian based distro: libpcre3-dev
  • FreeBSD: pcre

duma: Compile with DUMA support. DUMA is a library to detect buffer overruns and under-runs. Dependencies (debian): duma

xcode: Set this flag to true to compile on OS X with Xcode 7+.

macport: Set this flag to true to compile on OS X with macports.

make sqlite=true experimental=true pcre=true

Compiling wth gcrypt: make gcrypt=true

make sqlite=true pcre=true experimental=true install

Installing, with external scripts:

make sqlite=true experimental=true ext_scripts=true

Testing (with sqlite, experimental and pcre)

make sqlite=true experimental=true pcre=true check

Compiling on OS X with macports (and all options):

gmake macport=true sqlite=true experimental=true pcre=true

Compiling on FreeBSD with better performance

gmake CC=gcc5 CXX=g++5

Automatic detection of CPU optimization is done at compile time. This behavior is not desirable when packaging Aircrack-ng (for a Linux distribution).

It can be overriden by creating common.cfg in the same directory as this file with the following settings when compiling on x86 (32 or 64 bit):

Using precompiled binaries

  • Use your package manager to download aircrack-ng
  • In most cases, they have an old version.
  • Install the appropriate «monitor» driver for your card (standard drivers doesn’t work for capturing data).
  • aircrack-ng suite is command line tools. So, you have to open a commandline Start menu -> Run. -> cmd.exe then use them
  • Run the executables without any parameters to have help

Documentation, tutorials, . can be found on https://www.aircrack-ng.org

See also manpages and the forum.

For further information check the README file

Источник

Поделиться с друзьями
КомпСовет
Adblock
detector